Inicio > Mis eListas > hcc > Mensajes

 Índice de Mensajes 
 Mensajes 1479 al 1498 
AsuntoAutor
Re: las hojas de Ricardo
Re: las hojas de daniel e
enlaces a mis fich paco
Re: ¿Como mantener JAVIERCE
RE: Fondo Rafael C
Re: enlaces a mis × Hell ×
Re: enlaces a mis Core
Re: navegador por Core
Re: Envio de formu × Hell ×
Re: Re: vincular 2 × Hell ×
Re: Envio de formu José Fra
Re: esas fuentecit str!pTM
Re: enlaces a mis Rafael C
Re: ¿Como mantener × Hell ×
RE: Maquetar texto Esteban
RE: Envio de formu Esteban
Re: Maquetar texto str!pTM
Re: Envio de formu Core
Re: Envio de formu Doane He
Re: Maquetar texto Doane He
 << 20 ant. | 20 sig. >>
 
HTML con Clase
Página principal    Mensajes | Enviar Mensaje | Ficheros | Datos | Encuestas | Eventos | Mis Preferencias

Mostrando mensaje 1462     < Anterior | Siguiente >
Responder a este mensaje
Asunto:[hcc] ¿Elementos en línea?
Fecha:Sabado, 29 de Junio, 2002  14:47:23 (+0200)
Autor:Benjamín Valero Espinosa <benjavalero @.....es>

Muy buenas, amigos colisteros. Mi duda es muy tonta. De lo que he leído en las
especificaciones y de lo aprendido a través de esta maravillosa lista, me ha
quedado claro que el elemento DIV es para bloques y SPAN para elementos en línea.
Hasta ahí perfecto. Ahora viene mi problemilla. Pongamos que tengo un DIV (capa o
como puñetas le llameis) y que dentro de él a su vez quiero incluir dos, pero no
uno arriba y otro abajo, sino "en la misma línea". No creo que haga falta hacer
el dibujito, ¿verdad? Jejeje. 
 
Claro, el problema es que el DIV siempre me crea un salto de línea. Para poner
el otro DIV al lado, sin usar posiciones absolutas, pues tengo que empezar a
ingeniármelas con el atributo 'clear' y todo eso. Pero claro, oh sorpresa,
descubro que si los DIVs interiores los pongo como SPANs, todo funciona
maravillosamente (incluso puedo alinearlos a pie de línea, centrados
verticalmente, o lo que quiera). 
 
Ahora mi pregunta es: Sí, esto funciona, pero ¿es sintácticamente correcto? Uso
el IE5 (perdonadme que no use NS, pero es que tengo un Pentium a 150 MHz y como
que rasca un pelín salvo que use la versión 3, que no es plan, jeje) y no me da
problemas. Gracias por vuestras opiniones. Sobre todo las de Superjuanra. Ciau. 
 
Benja 
 
 
_______________________________________________________ 
 
Visita mi "güé peich" personal en http://usuarios.tripod.es/bvalero/ 
o mi humilde página de acordes en http://www.bvalero.galeon.com